通达信中长线买卖点主图指标公式

返回列表
通达信公式 163
公式说明

SJ:=IF(DATE+19000000<20191128,1,0);

X1:=EMA(CLOSE,8)*SJ,COLORWHITE;

X3:=EMA(X1,16)*SJ,COLORRED;

B:=BARSLAST(DAY<>REF(DAY,1))+1;

VAR2:=(CLOSE+HIGH+LOW)/3;

VAR3:=EMA(VAR2,10);

VAR4:=REF(VAR3,1);

STICKLINE(VAR3*SJ>VAR4,VAR3,VAR4,2 ,0),COLORRED;

STICKLINE(VAR3< VAR4*SJ,VAR3,VAR4,2,0), COLORGREEN;

W:=BARSLAST(DATE<>REF(DATE,1));

OO:=REF(OPEN,W);

HX:=HHV(HIGH,3);

LX:=LLV(LOW,3);

H1:=IF(HX<REF(HX,1)&&HX<REF(HX,2)&&HX<REF(HX,4)&&LX<REF(LX,1)&&LX<REF(LX,3)&&LX<REF(LX,5)&&OPEN>CLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);

L1:=IF(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN<CLOSE&&(CLOSE-LLV(OPEN,0))>0,REF(LX,4),0);

H2:=VALUEWHEN(H1>0,H1);

L2:=VALUEWHEN(L1>0,L1);

K111:=IF(CLOSE>H2,-3,IF(CLOSE<L2,1,0));

K222:=VALUEWHEN(K111<>0,K111);

TMP:=K222;

MA55:=MA(CLOSE,55);

DRAWTEXT(CROSS(TMP*SJ,0) ,HX,'卖空'),COLORGREEN;

DRAWTEXT(CROSS(0,TMP*SJ),LX,'买多)'),COLORRED;

DRAWICON(CROSS(TMP*SJ,0) ,HX,39),COLORGREEN,DRAWABOVE;

DRAWICON(CROSS(0,TMP*SJ),LX,38),COLORRED;

YJD:=IF(DATE+19000000>20191126,1,0);

DRAWTEXT_FIX(ISLASTBAR=1 AND YJD,0.1,0.2,0,' '),COLORYELLOW;

点击下载通达信公式调试用软件>>
赞赏本站

如果本站对您有所帮助,请打开您的微信,扫一扫下面的二维码,赞助本站,金额随意

算是您支持我们的发展,和对我们工作努力的肯定!小编在些表示感谢!


weix.jpg


联系客服:
客服 客服2
返回课程列表